mxv????

mxv - MXDRV World Vision Version 1.15c

Copyright (C) 2000 GORRY.

mxvは、X68000用音楽演奏システム「MXDRV」用データ（*.mdx）を演奏できるビジュアルプレイヤーです。

1ファイラーでmdxファイルを選び、演奏することができます。

2自動演奏機能により、フォルダ内のmdxファイルを連続演奏することができます。

3全チャンネルの状態をリアルタイムディスプレイにより確認できます。

4背景画像や文字色などを「テーマ」として一元管理できます。


??????????????

起動とアンインストールの方法

MXDRVg(v1.40a以降）をまず導入してください。

配布アーカイブファイルを解凍し、mxv.exeをダブルクリックすることで、起動します。

ESCキー（または右クリック）を押し、[終了]を選ぶと、mxvを終了します。

*.mdx ファイルをmxvに関連付けることで、エクスプローラからmdxファイルをmxvで演奏させることができます。

mxvはレジストリを使用していません。アンインストールは、ファイルの削除のみで構いません。

※GUSA-CDg版補足

インストールはインストーラにより行われます。アンインストールは、［設定］→［アプリケーションの追加と削除］にある、「GUSA-CDgアンインストーラ」でアンインストールしてください。


????????

画面と操作の説明

mxvを起動すると、以下の画面が表示されます。

●鍵盤

演奏している音階が、各チャンネルごとに表示されます。上からFMチャンネル１～８、９段めがPCMチャンネルです。

FMチャンネルの場合は、音色番号ごとにキーが色分け表示されます。

PCMチャンネルの場合は、１～８チャンネルが赤・橙・黄・緑・水色・青・紫・赤紫で表示されます。

●ステータス

演奏中のチャンネルの情報が表示されます。表示項目は以下のとおりです。

Width1Width3Width1691 Width3Width3610 Width3Width1718 音量(V) | 音量バー |  |  |  | パンポット(P)Width1Width3Width1691 Width3Width3610 Width3Width1718
Width1Width3Width1691 Width3Width1881 Width3Width1729 Width3Width1718 デチューン(D) | 音色番号(@) |  | ゲート(Q) |  | アドレスWidth1Width3Width1691 Width3Width1881 Width3Width1729 Width3Width1718
Width1Width3Width1691 Width3Width1190 Width3Width1210 Width3Width1210 Width3Width1718 音程LFO(MP) | 波形(#1) | 周期(#2) |  | 振幅(#3) | ディレイ(MD)Width1Width3Width1691 Width3Width1190 Width3Width1210 Width3Width1210 Width3Width1718
Width1Width3Width1691 Width3Width1190 Width3Width1210 Width3Width1210 Width3Width1718 音量LFO(MA) | 波形(#1) | 周期(#2) |  | 振幅(#3) | Width1Width3Width1691 Width3Width1190 Width3Width1210 Width3Width1210 Width3Width1718

波形は”～”などの記号で示されます。

●プレイキー

演奏指示を与えます。

Width1Width3Width2880 Width3Width5363 | 演奏時間と時刻（位置）を示します。クリックすることで、好きな位置（時刻）から再生できます。Width1Width3Width2880 Width3Width5363
Width1Width3Width2880 Width3Width5363 | Width1Width3Width2880 Width3Width5363
 | 音量を示します。ドラッグすることで、音量を調整できます。Width1Width3Width2880 Width3Width5363
 | Width1Width3Width2880 Width3Width5363
 | ONにすると、ファイラー内の全曲を連続で演奏します。Width1Width3Width2880 Width3Width5363
 | Width1Width3Width2880 Width3Width5363
 | ONにすると、リピート演奏します。 と一緒にONにすると、ファイラー内の全曲をリピート演奏します。Width1Width3Width2880 Width3Width5363
 | Width1Width3Width2880 Width3Width5363
 | 前（ファイラー上でひとつ上）の曲を演奏します。Width1Width3Width2880 Width3Width5363
 | Width1Width3Width2880 Width3Width5363
 | 演奏を終了します。Width1Width3Width2880 Width3Width5363
 | Width1Width3Width2880 Width3Width5363
 | 演奏を開始（あるいは再開）します。Width1Width3Width2880 Width3Width5363
 | Width1Width3Width2880 Width3Width5363
 | 演奏を一時停止します。もう一度押すと一時停止を解除します。Width1Width3Width2880 Width3Width5363
 | Width1Width3Width2880 Width3Width5363
Width1Width3Width2880 Width3Width5363 | 次（ファイラー上でひとつ下）の曲を演奏します。Width1Width3Width2880 Width3Width5363

●ファイラー

mdxファイルと移動できるフォルダ・ドライブを一覧表示します。マウスによる操作のほか、以下のキー入力による操作が可能です。

Width1Width3Width2340 Width3Width5903 カーソル PageUp/Down | カーソルを移動します。Width1Width3Width2340 Width3Width5903
Width1Width3Width2340 Width3Width5903 | Width1Width3Width2340 Width3Width5903
Enter | ファイルの演奏、またはフォルダの移動をします。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Backspace | ひとつ上のフォルダに移動します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
\ | ルートフォルダに移動します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
L | 移動フォルダをツリーから選択します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+1~8 | FMチャンネル１～８のマスクをON/OFFします。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+0 | 全FMチャンネルのマスクをOFFします。全チャンネルのマスクがOFFされている場合は、逆にONします。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Alt+1~8 | PCMチャンネル１～８のマスクをON/OFFします。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Alt+0 | 全PCMチャンネルのマスクをOFFします。全チャンネルのマスクがOFFされている場合は、逆にONします。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Alt+Ctrl+0 | 全チャンネルのマスクをOFFします。全チャンネルのマスクがOFFされている場合は、逆にONします。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+A | 早送りを終了します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+C | 演奏を終了します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+D | 早送りを開始します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+E | 全チャンネルのマスクをOFFします。全チャンネルのマスクがOFFされている場合は、逆にONします。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+F | フェードアウトを開始します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+I | 「mxvとMXDRVgの設定」ダイアログを開きます。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+N | 次の曲を演奏します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+O | mdxファイルをファイルダイアログから選んで演奏します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+Q | 一時停止している演奏を再開します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+P | 前の曲を演奏します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+R | 再演奏します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+S | 演奏を一時停止します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+V | 「テーマの設定」ダイアログを開きます。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Ctrl+O | mdxファイルをファイルダイアログから選んで演奏します。Width1Width3Width2340 Width3Width5903
 | Width1Width3Width2340 Width3Width5903
Width1Width3Width2340 Width3Width5903 ESC | メニューを表示します。Width1Width3Width2340 Width3Width5903


mxv???

mxvの設定

mxvの動作を設定します。

ファイラー

●フォルダ名を先に表示

ファイラーの表示に、mdxファイルより先にフォルダ名を表示します。

●FDドライブをファイラーに表示する

現状ほとんど使われることのないFDドライブを表示したくないときは、このチェックを外してください。

●大きい文字で表示する

ファイラー表示の文字が大きくなります。高解像度スクリーンで使用していて、ファイラーの文字が小さく見にくいと感じたらこのチェックをONにしてみてください。

演奏

●無限ループ曲のループ回数

無限ループする曲を演奏したときの、フェードアウトの始まるタイミングを指定します。"2"を指定すると、２回ループしたあとフェードアウトが始まります。


MXDRVg???

MXDRVgの設定

MXDRVgの動作を設定します。

X68Soundの設定

●再生周波数

サウンドデバイスに送るデータ形式を設定します。44KHzのほうが高音質ですが、CPUパワーを多く必要とします。

●割り込み間隔

OPM割り込みをエミュレーションするための割り込み間隔を設定します。小さいほどCPU負荷が高くなりますが、演奏タイミングが正確になります。

●PCM変換バッファサイズ

ADPCMデータをPCMデータに変換するためのバッファサイズを指定します。

●発声バッファサイズ

サウンドデータを一時的に貯めておくバッファサイズを設定します。小さいほどリアルタイム性が上がり、PLAYキーを押してから実際に演奏されるまでなどの時間が短くなってレスポンスが向上しますが、ディスクアクセスなどによる音声の途切れが発生しやすくなります。

●初期値に戻す

上記の設定を標準値に戻します。ほとんどのPCで快適となる値を設定します。

※あまり小さい値を設定すると、負荷が高くなりすぎてPCの操作が不可能になることがあります。

MDXの設定

●バッファサイズ

mdxファイルを読み込むバッファのサイズを設定します。mdxファイルは64KB程度までが仕様上の制限であるため、デフォルトの64KBから変更する必要は普通ありません。

PDXの設定

●PDXフォルダ

pdxファイルを検索するデフォルトフォルダを指定します。mxvはまずmdxファイルと同じフォルダにあるpdxファイルを探し、見つからなければここで示されたフォルダを探します。

●バッファサイズ

pdxファイルを読み込むバッファのサイズを設定します。1MBを超えるpdxファイルを読み込むときは、よ大きな値を設定してください。

●PCM8を使用する

PCMを８チャンネル同時演奏します。通常は変更する必要はありません。


??????

テーマの設定

mxvでは、表示画面の設定を「テーマ」として保存することができます。このダイアログは、それらのテーマを作成したり、インポート（読み込み）したりすることができます。

●テーマの一覧

現在使用できるテーマの一覧が表示されています。「Default」は、初回起動時に自動的に作られるテーマです。

●インポート

配布されているテーマをmxvに読み込み、使用できるようにします。

●新規

新しいテーマを作成します。テーマ名を入力するダイアログに答えたあと、テーマ編集を行います。

●編集

「テーマの一覧」で指定したテーマを編集します。

テーマファイルについて

テーマは、その設定ファイル（mxvテーマファイル）と、背景画像ファイル（bmpファイル）の２つから構成されます。テーマ名を"theme"とした場合、設定ファイル"theme.mxv"が作られ、背景に画像ファイルを使用するならば"theme.bmp"というファイルがさらに作られます。

テーマファイルは、mxv.exeをインストールしたフォルダに作られます。前述の例なら、インストールフォルダに"theme.mxv"と"theme.bmp"が作られます。


??????-??

テーマの編集－背景

背景の表示設定をします。１枚のbmp画像と、それに被せる色を設定できます。

背景

●背景に画像を表示する

背景に画像ファイルを使用するなら、このチェックをONにします。

●合成比

背景画像の合成比（透明度）を設定します。

●画像をインポート

外部からbmp画像ファイルを読み込みます。

背景画像は非圧縮のbmpファイルでなければなりません。サイズに制限はありませんが、mxvのウィンドウサイズは640ﾗ480ドット固定です。

●背景色

bmp画像に被せる色とその合成比（透明度）を指定します。


??????-????????

テーマの編集－鍵盤とステータス

鍵盤とステータスの表示設定をします。

鍵盤

●白鍵の明るさ

白鍵の明るさを設定します。0を中心（透明）に、大きいほど白く、小さいほど黒くなります。

●黒鍵の明るさ

黒鍵の明るさを設定します。0を中心（透明）に、大きいほど白く、小さいほど黒くなります。

●押鍵の合成比

押されている鍵盤の合成比（透明度）を設定します。

ステータス

●文字色

ステータスとして表示する文字の色と合成比（透明度）を指定します。

●背景色

ステータス部分の背景色と合成比（透明度）を指定します。


??????-????????

テーマの編集－曲名とファイラー

曲名とファイラーの表示設定をします。

曲名

●文字色

曲名として表示する文字の色と合成比（透明度）を指定します。

●背景色

曲名部分の背景色と合成比（透明度）を指定します。

ファイラー

●カーソル

カーソルの明るさをR（赤）・G（緑）・B（青）の成分ごとに指定します。

●文字色

ファイラーに表示されるmdxファイルの文字の色と合成比（透明度）を指定します。

合成比は、フォルダ・ドライブの表示に対しても同時に機能します。

●フォルダ

ファイラーに表示されるフォルダの文字の色を指定します。

●ドライブ

ファイラーに表示されるドライブの文字の色を指定します。

●背景色

ファイラー部分の背景色と合成比（透明度）を指定します。


??????-????

テーマの編集－操作キー

操作キーの表示設定をします。

操作キー

●文字色

操作キー部に表示する文字の色と合成比（透明度）を指定します。

●プレイキー

操作キーの表面の明るさを指定します。0を中心（透明）に、大きいほど白く、小さいほど黒くなります。


???

その他

mxvは、自由に使用・配布・改変を行うことができます。これらは無保証であり、使用した、あるいはしなかったことによる一切の責任は所有者にあるものとします。

連絡は以下までお願いいたします。

Email:GORRY@hauN.org

URL:http://GORRY.hauN.org/

[EOF]